$re = '/\b\w*\s*-\s*\w*\b/';
$str = 'word1-word2
asdfsf sf word1-word2 sdf sdf
word1 - word2
word1 word2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);