// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b\w*\s*-\s*\w*\b").unwrap();
let string = "word1-word2
asdfsf sf word1-word2 sdf sdf
word1 - word2
word1 word2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}