re = /\b\w*\s*-\s*\w*\b/
str = 'word1-word2
asdfsf sf word1-word2 sdf sdf
word1 - word2
word1 word2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end