# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\+]?\d{0,3}([(]?\d{3}[)]?[-.]?\d{3}[-.]?\d{2}[-.]?\d{2})/$1/g;t' <<< "984-169-3656 984.169.36.56 (984)-169-36-56 +5219841693656 +529841693656"