#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[\+]?\d{0,3}([(]?\d{3}[)]?[-.]?\d{3}[-.]?\d{2}[-.]?\d{2})"
Local $sString = "984-169-3656 984.169.36.56 (984)-169-36-56 +5219841693656 +529841693656"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)