using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\+]?\d{0,3}([(]?\d{3}[)]?[-.]?\d{3}[-.]?\d{2}[-.]?\d{2})";
string substitution = @"$1";
string input = @"984-169-3656 984.169.36.56 (984)-169-36-56 +5219841693656 +529841693656";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}