use strict;
my $str = '984-169-3656 984.169.36.56 (984)-169-36-56 +5219841693656 +529841693656';
my $regex = qr/[\+]?\d{0,3}([(]?\d{3}[)]?[-.]?\d{3}[-.]?\d{2}[-.]?\d{2})/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";