import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\"[^\"]*\",){1}\"([^\"]*)\"";
final String string = "\"01\",\"35005\",\"AL\",\"ADAMSVILLE\",86.959727,33.588437,10616,0.002627\n"
+ "\"05\",\"72001\",\"AR\",\"ADONA\",92.903325,35.046956,494,0.00021\n"
+ "\"06\",\"90804\",\"CA\",\"SIGNAL HILL\",118.155187,33.782993,36092,0.001213";
final String subst = "$1chat/$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}