#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https?:\/\/(?:[^. ]+\.)*(?P<test>[\w-]+\.[\w-]+)"
Local $sString = "TEXT TEXT TEXT TEXT , URL: http://www.rexegg.com/regex-boundaries.html, TEXT TEXT https://a248.e.akamai.net/, TEXT TEXT http://rexegg.com/regex-boundaries.html and http://mail.yahoo.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")