import Foundation
let pattern = #"(?i)https?:\/\/(?:[^. ]+\.)*(?P<test>[\w-]+\.[\w-]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"TEXT TEXT TEXT TEXT , URL: http://www.rexegg.com/regex-boundaries.html, TEXT TEXT https://a248.e.akamai.net/, TEXT TEXT http://rexegg.com/regex-boundaries.html and http://mail.yahoo.com/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)