use strict;
my $str = 'TEXT TEXT TEXT TEXT , URL: http://www.rexegg.com/regex-boundaries.html, TEXT TEXT https://a248.e.akamai.net/, TEXT TEXT http://rexegg.com/regex-boundaries.html and http://mail.yahoo.com/';
my $regex = qr/(?i)https?:\/\/(?:[^. ]+\.)*(?P<test>[\w-]+\.[\w-]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}