package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)https?:\/\/(?:[^. ]+\.)*(?P<test>[\w-]+\.[\w-]+)`)
var str = `TEXT TEXT TEXT TEXT , URL: http://www.rexegg.com/regex-boundaries.html, TEXT TEXT https://a248.e.akamai.net/, TEXT TEXT http://rexegg.com/regex-boundaries.html and http://mail.yahoo.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}