#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:^|[^\/?$])(\bfoo\b)"
Local $sString = "foo - need this" & @CRLF & _
"<div>foo</div> - need this" & @CRLF & _
"" & @CRLF & _
"Foo - dont need this" & @CRLF & _
"foobar - dont need this" & @CRLF & _
"/foo/ "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")