re = /(?:^|[^\/?$])(\bfoo\b)/
str = 'foo - need this
<div>foo</div> - need this
Foo - dont need this
foobar - dont need this
/foo/ '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end