// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^|[^\/?$])(\bfoo\b)").unwrap();
let string = "foo - need this
<div>foo</div> - need this
Foo - dont need this
foobar - dont need this
/foo/ ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}