package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|[^\/?$])(\bfoo\b)`)
var str = `foo - need this
<div>foo</div> - need this
Foo - dont need this
foobar - dont need this
/foo/ `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}