$re = '~-?\b\d+(?:\.\d+)?(?:/\d+(?:\.\d+)?)?\b~';
$str = '3.1/2.6
1.00/5.00
12/19
125
12.34
-567.89';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);