import re
regex = re.compile(r"-?\b\d+(?:\.\d+)?(?:/\d+(?:\.\d+)?)?\b")
test_str = ("3.1/2.6\n"
"1.00/5.00\n"
"12/19\n"
"125\n"
"12.34\n"
"-567.89")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")