using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Your Updated Reservation Confirmation (?:#\s?)?\d+ at .+";
string input = @"Your Updated Reservation Confirmation # 68876759 at Holiday Inn Express.
Your Updated Reservation Confirmation at Holiday Inn Hotel & Suites - Confirmation # 64754230
Your Updated Reservation Confirmation at Crowne Plaza - Confirmation # 68003047";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}