// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Your Updated Reservation Confirmation (?:#\s?)?\d+ at .+").unwrap();
let string = "Your Updated Reservation Confirmation # 68876759 at Holiday Inn Express.
Your Updated Reservation Confirmation at Holiday Inn Hotel & Suites - Confirmation # 64754230
Your Updated Reservation Confirmation at Crowne Plaza - Confirmation # 68003047";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}