import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Your Updated Reservation Confirmation (?:#\\s?)?\\d+ at .+";
final String string = "Your Updated Reservation Confirmation # 68876759 at Holiday Inn Express.\n\n"
+ "Your Updated Reservation Confirmation at Holiday Inn Hotel & Suites - Confirmation # 64754230\n\n"
+ "Your Updated Reservation Confirmation at Crowne Plaza - Confirmation # 68003047";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}