package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Your Updated Reservation Confirmation (?:#\s?)?\d+ at .+`)
var str = `Your Updated Reservation Confirmation # 68876759 at Holiday Inn Express.
Your Updated Reservation Confirmation at Holiday Inn Hotel & Suites - Confirmation # 64754230
Your Updated Reservation Confirmation at Crowne Plaza - Confirmation # 68003047`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}