#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)x(\d+)|-\s*([\w\s]+)|(\w+)"
Local $sString = "21x04 - Some Text (04)" & @CRLF & _
"6x03 - Some Text (00 - Some Text)" & @CRLF & _
"6x03 - Some Text (00 - Some Text) (Some Text)" & @CRLF & _
"23x01 - Some Text (10) - Some Text (02)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")