re = /(\d+)x(\d+)|-\s*([\w\s]+)|(\w+)/m
str = '21x04 - Some Text (04)
6x03 - Some Text (00 - Some Text)
6x03 - Some Text (00 - Some Text) (Some Text)
23x01 - Some Text (10) - Some Text (02)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end