package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)x(\d+)|-\s*([\w\s]+)|(\w+)`)
var str = `21x04 - Some Text (04)
6x03 - Some Text (00 - Some Text)
6x03 - Some Text (00 - Some Text) (Some Text)
23x01 - Some Text (10) - Some Text (02)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}