const regex = /(\d+)x(\d+)|-\s*([\w\s]+)|(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)x(\\d+)|-\\s*([\\w\\s]+)|(\\w+)', 'gm')
const str = `21x04 - Some Text (04)
6x03 - Some Text (00 - Some Text)
6x03 - Some Text (00 - Some Text) (Some Text)
23x01 - Some Text (10) - Some Text (02)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}