# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<p>.*?\K<br\\/>(?!<\\/p>)//gm;t' <<< "<p><br/>Hello World</p>
<p><br/>Hello <br/> World</p>
<p><br/></p>"