const regex = /<p>.*?\K<br\/>(?!<\/p>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>.*?\\K<br\\\/>(?!<\\\/p>)', 'gm')
const str = `<p><br/>Hello World</p>
<p><br/>Hello <br/> World</p>
<p><br/></p>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);