$re = '/<p>.*?\K<br\/>(?!<\/p>)/m';
$str = '<p><br/>Hello World</p>
<p><br/>Hello <br/> World</p>
<p><br/></p>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;