re = /<p>.*?\K<br\/>(?!<\/p>)/m
str = '<p><br/>Hello World</p>
<p><br/>Hello <br/> World</p>
<p><br/></p>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result