using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+27|27|0)\s?(\d{2})[-\s]?(\d{3})[-\s]?(\d{4})$";
string input = @"+27 11-2345678";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}