const regex = /^(\+27|27|0)\s?(\d{2})[-\s]?(\d{3})[-\s]?(\d{4})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+27|27|0)\\s?(\\d{2})[-\\s]?(\\d{3})[-\\s]?(\\d{4})$', '')
const str = `+27 11-2345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}