import Foundation
let pattern = #"^(\+27|27|0)\s?(\d{2})[-\s]?(\d{3})[-\s]?(\d{4})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"+27 11-2345678"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}