$re = '/^(\+27|27|0)\s?(\d{2})[-\s]?(\d{3})[-\s]?(\d{4})$/';
$str = '+27 11-2345678';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);