const regex = /jeroboam|magnum|([0-9]+[,.][0-9]{1,3})|([\s?][0-9]{1,2}[\s?])/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('jeroboam|magnum|([0-9]+[,.][0-9]{1,3})|([\\s?][0-9]{1,2}[\\s?])', 'ig')
const str = `1.5 Primitivo 3 di Manduria 15 Doppelmagnum 2016 1,5 0,375 0,25 Magnum Jeroboam 6,2Liter`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}