// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)jeroboam|magnum|([0-9]+[,.][0-9]{1,3})|([\s?][0-9]{1,2}[\s?])").unwrap();
let string = "1.5 Primitivo 3 di Manduria 15 Doppelmagnum 2016 1,5 0,375 0,25 Magnum Jeroboam 6,2Liter";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}