# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"jeroboam|magnum|([0-9]+[,.][0-9]{1,3})|([\s?][0-9]{1,2}[\s?])"
test_str = "1.5 Primitivo 3 di Manduria 15 Doppelmagnum 2016 1,5 0,375 0,25 Magnum Jeroboam 6,2Liter"
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.