$re = '/jeroboam|magnum|([0-9]+[,.][0-9]{1,3})|([\s?][0-9]{1,2}[\s?])/i';
$str = '1.5 Primitivo 3 di Manduria 15 Doppelmagnum 2016 1,5 0,375 0,25 Magnum Jeroboam 6,2Liter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);