const regex = /((?:\h*(?:RE|FW|FWD):)*)(.*)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\h*(?:RE|FW|FWD):)*)(.*)', 'i')
const str = `RE: RE:RE: RE:FW: FWD: re: Dit is een email over software re: asdf `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}