re = /((?:\h*(?:RE|FW|FWD):)*)(.*)/i
str = 'RE: RE:RE: RE:FW: FWD: re: Dit is een email over software re: asdf '
# Print the match result
str.match(re) do |match|
puts match.to_s
end