$re = '/((?:\h*(?:RE|FW|FWD):)*)(.*)/i';
$str = 'RE: RE:RE: RE:FW: FWD: re: Dit is een email over software re: asdf ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);