using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<td><a href=""\/xxx\.html\?n=123"">).*?(<\/a><span)";
string input = @"<td><a href=""/xxx.html?n=123"">Aishfoihg</a><span";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}