package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mis)(<td><a href="\/xxx\.html\?n=123">).*?(<\/a><span)`)
var str = `<td><a href="/xxx.html?n=123">Aishfoihg</a><span`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}