re = /(<td><a href="\/xxx\.html\?n=123">).*?(<\/a><span)/mi
str = '<td><a href="/xxx.html?n=123">Aishfoihg</a><span'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end