$re = '/(<td><a href="\/xxx\.html\?n=123">).*?(<\/a><span)/mis';
$str = '<td><a href="/xxx.html?n=123">Aishfoihg</a><span';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);