#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(?:\d{1,3}(?:,\d{3})*|\d+)(?:,0+)?$"
Local $sString = "Valid Match : " & @CRLF & _
"1,000" & @CRLF & _
"111" & @CRLF & _
"-1000,00" & @CRLF & _
"" & @CRLF & _
"Invalid Match : " & @CRLF & _
"-,1" & @CRLF & _
"1,,,,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")