$re = '/^-?(?:\d{1,3}(?:,\d{3})*|\d+)(?:,0+)?$/m';
$str = 'Valid Match :
1,000
111
-1000,00
Invalid Match :
-,1
1,,,,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);