package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?(?:\d{1,3}(?:,\d{3})*|\d+)(?:,0+)?$`)
var str = `Valid Match :
1,000
111
-1000,00
Invalid Match :
-,1
1,,,,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}