// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?(?:\d{1,3}(?:,\d{3})*|\d+)(?:,0+)?$").unwrap();
let string = "Valid Match :
1,000
111
-1000,00
Invalid Match :
-,1
1,,,,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}