using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# From object name = value
( # (1 start)
"" \s* \w+ \s* "" \s* :
(?! \s* "" ) # not a string
(?! # not a number
\s* \d+ \s*
(?: , | \] | } )
)
(?! \s* [{\[] ) # not a object or array
(?! # not true,false or null
\s*
(?: true | false | null )
\s*
(?: , | \] | } )
)
\s*
) # (1 end)
( .+? ) # (2)
(?= [,}] )";
string substitution = @"$1""$2""";
string input = @" {""Id"": ""2017"",
""Currency"": ""AUD"",
""Date"": 2020-06-22,
""InCash"": 0.000,
""Dep"": ""ABC90"",
""sdf"" : 739,
""sumCash"": 770.87,
""AnotherDate"": 2020-06-21}";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}